‹  返回课程

安装并升级Code::Blocks

课文
阅读量:520
技术范畴
完成三件事:准备统一安装目录、下载并安装17.12版本的发行版,然后下载最新构建版覆盖以升级。其间需检测电脑系统是否为64位。
课前导言
  1. 注意视频课程相比《白话C++》书的内容变动,包括:统一安装路径的位置、Code::Blocks的发行版与构建版、以及系统是否64位的检测。
  2. 确记如果在32位系统上安装C::B,在安装17.12发行版即可停止。
  3. 另外,您可能需要下载 7-Zip相关软件用于解压。
安装并升级Code::Blocks
下载当前Code::Blocks最新发行版并安装,然后再下载最新构建版升级。

1. 准备统一安装目录

按 《白话 C++》书中要求,我们将IDE、编译器、各个第三方库,都统一安装在一个目录下。书中使用 d:cpp。本视频课程在录制时,所用电脑的d盘是一张存储卡(读写性能差),因此使用 c:cpp。

请各位读者依据自己的实际情况,创建该目录。

2. 下载并安装最新发行版

《白话C++》书中下载的是16.01发行版,但本视频课程使用17.12发行版。

注:发行版就是在某一阶段,已有功能完成度较高,BUG较少的,相对正式的版本。

Code::Blocks官方截止当前(2019年7月)提供的最新发行版是17.12,即2017年12月的版本,已经显得比较“老旧”了。不过,官方提供“每日(夜)构建版”,虽然不是真正的每日提供,但更新频率较高。

所以,我们的操作就是:先下载最新发行版,安装,然后再下载最新构建版,覆盖,以得到一个较新的Code::Blocks,同时拥有桌面图标、开始菜单组等Windows程序的日常功能。

3. 下载并更新最新构建版

  • 注意点:需要先检查你的电脑及操作系统是否64位的。 如果是32位系统,那么就不用往下做,使用 17.12版本即可(已经比书中的版本新)。

  • 注意点:由于我们现在是第一次升级,所以必须额外下载两个Code::Blocks运行需要的环境文件。 提示点:下载后的文件扩展名是 .7Z 文件,所以你可能需要准备 7-Zip 或其它解压软件。


课后补充
Code::Blocks是一款主要用于C++编程的IDE,即“集成开发环境”,现在我们可以使用它来写C++代码,但还无法编译,下一节将下载C++编译器,并完成它在Code::Blocks中的集成配置。